HorsepowerJunkies.com Forums
 
 

 

Advertisement

 


Go Back   HorsepowerJunkies.com Forums > Car Related Discussion > The Garage

Please visit our local sponsor:

Sponsor

 

Please visit our local sponsor:

Sponsor


Reply
 
Thread Tools Display Modes
Old 05-17-2022, 05:29 PM   #1
rcktpwrd
Registered User
 
Join Date: Dec 2013
Location: Raleigh, NC
Posts: 816
rcktpwrd best poster evAr!!!!!!111rcktpwrd best poster evAr!!!!!!111rcktpwrd best poster evAr!!!!!!111
Exclamation fuel pump wiring...

We got stuck the other night with the wagon. Luckily, we were at our destination but had to get a tow home and luckily we have a buddy with a truck and trailer that was willing to help!

Car dies and would crank just fine but not fire. I suspected the fuel pump hose broke as it seems to be an issue with these cars. When I got into trouble shooting I couldn't here or feel the fuel pump running at all.

Dropped the fuel tank, fought with the 'quick' connect fittings a bit as I could only reach them with one outstreatched hand. Fortunately there was only about a 1/3 tank of gas.

Pulled the fuel sender assembly out and found this:





Pump/sender assembly was about three years old, I installed it when we got the car.

Found a pump and wiring harness kit locally and got it fixed up.
__________________
Joel
his: 1976 Olds Cutlass S
hers: 1990 Chevy 454SS
rcktpwrd is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:09 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
All graphics and text no matter how childish and offensive are the property of HorsepowerJunkies.com. Do not use or recreate without permission.
 

Advertisement

 


...